Proxmox upgrade a la versión 6

En esta ocación realizaremos la actualización a la versión a nivel host o servidor desde la ultima versión actualizada 5.x

Para lo cual
Paso#1 : Actualizar a la ultima version 5.x  (https://nucleolabs.wordpress.com/2019/07/30/proxmox-actualizar-versiones-5-x/)

Paso #2: Validar que el host o servidor lo soporta , ejecutar el

pve5to6

= SUMMARY =

TOTAL: 15
PASSED: 13
SKIPPED: 2
WARNINGS: 0
FAILURES: 0    <— tiene que salir 0 errores , sino corregirlo

Paso 3: Cambiar el repo de Corosyn

echo "deb http://download.proxmox.com/debian/corosync-3/ stretch main" > /etc/apt/sources.list.d/corosync3.list

Luego:

apt update

apt list –upgradable   <– se verifica lo que podamos actualizar

apt dist-upgrade  <– ejecutamos el cambio

Paso #4: Cambiar el repo de Debian

sed -i 's/stretch/buster/g' /etc/apt/sources.list

Antes tenias la version de stretch ahora buster

Ademas del PVE no Official

root@nodo3:~# cat /etc/apt/sources.list.d/pve-enterprise.list
#deb https://enterprise.proxmox.com/debian/pve stretch pve-enterprise
deb http://download.proxmox.com/debian buster pve-no-subscription

Y Ceph

echo "deb http://download.proxmox.com/debian/ceph-luminous buster main" > /etc/apt/sources.list.d/ceph.list

Finalmente :

apt update
y Luego :
apt dist-upgrade

Paso #5: Verificar  y remover

root@nodo3:~# pveversion
pve-manager/6.0-5/f8a710d7 (running kernel: 4.15.18-19-pve)

rm /etc/apt/sources.list.d/corosync3.list

 

Responder

Por favor, inicia sesión con uno de estos métodos para publicar tu comentario:

Logo de WordPress.com

Estás comentando usando tu cuenta de WordPress.com. Cerrar sesión /  Cambiar )

Google photo

Estás comentando usando tu cuenta de Google. Cerrar sesión /  Cambiar )

Imagen de Twitter

Estás comentando usando tu cuenta de Twitter. Cerrar sesión /  Cambiar )

Foto de Facebook

Estás comentando usando tu cuenta de Facebook. Cerrar sesión /  Cambiar )

Conectando a %s

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios .